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How to Create Accessible 
Adobe PDF Files

 

Welcome to Adobe® Systems Incorporated’s 

 

How To Create Accessible Adobe PDF 
Files

 

, a step-by-step guide that covers the basics for creating and optimizing 
Adobe Portable Document Format (PDF) files so that they can be made accessible 
to users with disabilities such as blindness or low vision.

This guide tells you how you can use Adobe Acrobat® 5.0 software and Adobe 
Acrobat Capture® 3.0 software to optimize your documents for distribution as 
Adobe PDF files that can be read easily with the aid of Windows®-based assistive 
technology such as screen readers.

 

About Adobe PDF 

 

Adobe Portable Document Format (PDF) is standard for electronic document 
distribution worldwide. Adobe PDF is a universal file format that preserves the 
exact look and feel of any source document, including all of the fonts, formatting, 
colors, and graphics, regardless of the application and platform used to create it. 
Adobe PDF files can be opened reliably across a broad range of hardware and 
software with the free Adobe Acrobat Reader™ software. You can convert any 
electronic document or Web page to Adobe PDF using Adobe Acrobat 5.0 
software, and any scanned page to searchable Adobe PDF using Adobe Acrobat 
Capture 3.0 software.

Adobe PDF is a standard on the World Wide Web and is also used to distribute 
electronic documents over corporate networks, via e-mail, and on CD-ROM. 
Many corporations, educational institutions, and government agencies use 
Adobe PDF to distribute documents to the public or to groups within their 
organizations. Adobe PDF is also gaining tremendous popularity as the basis for 
new e-business and e-government processes. Its support for electronic forms, 
digital signatures, password security, and electronic mark-ups make it the ideal 
platform for converting yesterday’s paper-based business processes to fully inter-
active digital processes.
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Authoring for Accessibility

 

Whether you’re publishing a document in HTML, Adobe PDF, or some other 
format, creating accessible documents requires much more than simply repre-
senting the original document accurately. Sighted people can look at a printed 
page and easily discern the difference between titles, subtitles, columns of text, 
headers, footers, and so on. Visual clues, such as location of the text on the page, 
bold text, and large font sizes help them determine the structure of a document 
so they can read and navigate it easily. 

Unfortunately, assistive technologies such as screen readers can't depend on these 
visual clues. They must instead rely on the underlying computer-based infor-
mation to provide that same structure. As a result, making documents accessible 
depends on two things:

 

•

 

Authoring the original documents so that they contain not just content (such 
as the text in the document) but also information about the structure of the 
content (such as how the text flows within the page and from page to page).

 

•

 

Using publishing tools such as Adobe Acrobat software and Adobe PDF 
technology that can retain and encode both the content and the structure 
so that it can be interpreted by assistive technology.

In order to do this:

 

•

 

Authors need to be aware of the importance of writing with the intent of 
creating accessible documents, and how to accomplish that.

 

•

 

Authoring and publishing tools can be enhanced to help authors create acces-
sible documents.

These same requirements apply to any type of publishing environment, 
regardless of the file format or application. If you want to make it possible for 
people with screen readers to navigate documents correctly, the underlying struc-
tural information must be present.
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About Adobe Acrobat Software

 

Adobe Acrobat 5.0 software provides a number of capabilities that improve 
access for disabled users. In particular, it:

 

•

 

Creates tagged Adobe PDF files when converting Microsoft Office 2000 files 
to Adobe PDF, making it easier for people who use screen reader software to 
navigate a document in the proper reading order.

 

•

 

Converts new and existing PDF files to tagged Adobe PDF files with the 
optional Make Accessible plug-in.

 

•

 

Includes tools to help troubleshoot and optimize Adobe PDF files for accessi-
bility, including the accessibility checker, the Tags palette, and more.

 

•

 

Supports the Microsoft® Active Accessibility (MSAA) Application 
Programming Interface (API) for the Windows platform for integration with 
assistive technology products, including screen readers from vendors such as 
GW Micro (www.gwmicro.com) and Freedom Scientific (www.freedomsci-
entific.com).

 

•

 

Provides usability enhancements, including enhanced keyboard shortcuts, 
support for high-contrast viewing, and the ability to zoom in and reflow text 
on the screen.

Adobe Acrobat Capture 3.0, meanwhile, is a powerful, flexible tool that lets you 
convert paper-based documents into accessible Adobe PDF files. This software:

 

•

 

Retains the exact look and feel of the original document while embedding a 
layer of searchable, accessible text using Optical Character Recognition (OCR) 
software.

 

•

 

Lets you review and fix suspect text quickly and easily with the QuickFix tool.

 

•

 

Eliminates random text by letting you pre-select areas of the page to treat as 
text or graphics.

 

•

 

Adds hyperlinks and bookmarks automatically so users can easily navigate 
tables of contents, indexes, and more.

 

•

 

Creates tagged Adobe PDF files when converting paper documents through 
use of the optional Tag Adobe PDF agent.

 

Important:

 

 The capabilities described in this guide require the Make Accessible plug-
in for Acrobat 5.0 and the Tag Adobe PDF agent for Acrobat Capture 3.0. See “Using 
the Make Accessible Plug-in” on page 20 and “Working with Scanned and Paper 
Documents” on page 13 for information on how to obtain these optional tools.



 

4
About this Guide

 

About this Guide

 

In this guide, you'll find the basic procedures and techniques you need to create 
accessible Adobe PDF files. Of course, your specific workflow will depend on the 
type of document you are starting with. This guide will show you how to do the 
following:

 

•

 

Author documents with the intent of making them accessible, with specific 
instructions on how to create structured documents in Microsoft Office 2000 
applications.

 

•

 

Create tagged Adobe PDF files using the Adobe PDFMaker plug-in for 
Microsoft Office applications.

 

•

 

Optimize existing Adobe PDF files for accessibility using the tools available 
in Acrobat 5.0.

 

•

 

Convert paper-based documents to accessible Adobe PDF files using Adobe 
Acrobat Capture 3.0 and the Tag Adobe PDF agent.

 

•

 

Build accessible forms in Acrobat 5.0.

This guide assumes you are familiar with the different applications described. 
For more detail on each application and feature, please refer to the user guide for 
that product.
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What is Accessibility?

 

Adobe is committed to providing solutions that improve accessibility to both 
Adobe Acrobat software and the information contained in Adobe PDF files. In 
the broadest sense, “accessibility” can mean providing access to people with a 
range of disabilities. For example, accessibility might mean providing ramps for 
people in wheelchairs, or writing documents in simple English with illustrations 
for someone with lesser reading comprehension.

When it comes to creating and publishing Adobe PDF files with Adobe Acrobat 
software, however, the range of disabilities that need to be addressed narrows 
considerably. 

Adobe Acrobat 5.0 includes usability enhancements such as:

 

•

 

Enhanced keyboard shortcuts for users with a broad range of disabilities, 
including motion impairment.

 

•

 

Support for high-contrast viewing, and the ability to zoom in and reflow text 
on the screen for users with low visual acuity.

 

•

 

Support for assistive technology such as screen readers through the MSAA 
API for the Windows platform.

Creating and optimizing files for use with assistive technology such as screen 
reader software may be the most complex issue addressed with Acrobat 5.0. 
Screen readers let visually disabled users interact with the computer by inter-
preting what is happening on the screen and sending that information to speech-
synthesis devices.



 

6
What is Accessibility?

 

Here are some things to consider to optimize your documents for accessibility 
and help screen reader applications use them:

 

Logical reading order.

 

Documents are more accessible if they have been 
authored with a logical structure in mind. Using application-based tools to define 
and create document structure such as titles, chapters, headings, and multi-
column text can make it easier for assistive technologies such as screen readers to 
understand the logical reading order of the content without any ambiguity. For 
example, if a document has been correctly authored using two columns to create 
a two-column format, the screen reader knows it should read all the way down 
the first column and then proceed to the second column. On the other hand, if 
the writer used tabs to imitate the look of two-column text, the screen reader 
would not recognize the layout as two-column. Instead, it would simply read 
horizontally, going from the first line in the first column and then tabbing over 
to the first line in the second column.

 

Alternate text descriptions for images. 

 

The document should contain written 
descriptions of images in the document. For example, you can use the Tags 
palette discussed later in this guide to add a description of an image. Then, when 
a screen reader encounters that image in the document, it will read the alternate 
text description so the user can understand what the image is about.

 

Scanned documents with accessible text.

 

A document that is based on a scanned 
paper document might not have searchable, accessible text. For instance, it may 
be a PDF Image Only file, which is simply a bitmapped image of a document 
embedded in a PDF file. Because PDF Image Only files do not contain text to 
which optical character recognition (OCR) has been applied, their content is not 
searchable. This means that an image of a page of text is still just an untranslatable 
image to a screen reader. But if the image file or PDF Image Only file is converted 
to a tagged Adobe PDF document and has OCR applied as part of that process 
(such as with Adobe Acrobat Capture 3.0), the screen reader will be able to 
recognize and read the document as text.
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Security with accessible text. 

 

A document's security settings will make it 
inaccessible to screen readers if it’s an Acrobat 4.0-compatible document and 
copying text and graphics is prohibited, or if it’s an Acrobat 5.0-compatible 
document and accessibility is prohibited. For instructions on how to retain 
security while allowing accessibility, see “Text is unreadable because the Adobe 
PDF document has been password protected, and content copying and extraction 
are not allowed.” on page 25.

 

Links.

 

The document should include useful links and other interactive page 
content, so that users can go directly to the section they want.

 

Navigation.

 

The document should include navigational and organization aids, 
such as a table of contents and useful headings. This provides an easy way for 
users to move through the document so that they don’t have to read the entire 
document page by page in order to find what they are looking for.

 

Document language.

 

Although current screen readers are designed to read the 
document according to one particular language, specifying the language of the 
document in the structure can benefit future screen reader technologies that may 
be able to change languages on the fly. In addition, the Accessibility Checker 
(discussed later in this guide) will mark this as an error if you do not specify a 
document language.
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Preparing Your Documents for Accessibility

 

Adobe Acrobat 5.0 software lets you create Adobe PDF files that contain logical 
document structure. 

 

Logical structure

 

 refers to the organization of the document, 
such as the title page, chapters, sections, and subsections. The logical structure 
can indicate the precise reading order and improve navigation, particularly for 
longer, more complex documents. Although Acrobat 4.0 provided structure 
information that allowed for a certain level of accessibility, Acrobat 5.0 lets you 
create 

 

tagged Adobe PDF

 

, which provides increased logical structure and as a 
result, increased accessibility. 

For example, tagged Adobe PDF:

 

•

 

Ensures that information is in the correct reading order on a page.

 

•

 

Includes paragraph attributes needed to reflow text correctly.

 

•

 

Ensures the reliable translation of all text into Unicode, which is a 
standardized approach to describing text characters, regardless of font. 
This approach understands ligatures and hyphens, so that all characters 
and words can be read correctly by a screen reader.

 

•

 

Enables the document to be exported reliably to Rich Text Format (RTF) for 
reuse in other documents.

 

Note:

 

 Acrobat 5.0 includes a version of Adobe PDFMaker that creates tagged Adobe 
PDF directly from Microsoft Office 2000 applications.

 

This following sections describe how to turn your files into tagged Adobe PDF 
using Acrobat 5.0.
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Working with Microsoft Office 2000 Application Files

 

When you install Acrobat 5.0, it installs Adobe PDFMaker 5.0 in your Windows 
Office 2000 applications. When you use PDFMaker 5.0 with Word 2000, 
Excel 2000, or PowerPoint 2000 you can create tagged Adobe PDF files that 
preserve hyperlinks, styles, bookmarks, and the structure of tables present in the 
source document.

 

Tips for making an accessible Adobe PDF file

 

Here are some things you can do to improve the quality of structure in your files, 
and therefore their accessibility:

 

•

 

Create your Word documents in Word 2000, rather than in Word 97. If 
they’re already in Word 97, open and save them in Word 2000. Word 2000 lets 
you create tagged Adobe PDF, which has greater functionality for accessibility 
than the structured Adobe PDF created from Word 97 documents.

 

•

 

When you write a document in Microsoft Word, be sure to use styles to format 
text such as titles, headings, and paragraphs. The styles provide structure 
information when you create a tagged Adobe PDF file. For example, do not 
use the Enter key to add space between paragraphs. Instead, use the “Spacing 
Before” and “Spacing After” paragraph properties to achieve this effect.

 

•

 

Use the Columns command in Word to create columns. Don’t use tabs to 
simulate double-column text.

 

•

 

Use the Insert Table command or Draw Table tool in Word to create tables. 

 

•

 

Add alternate text to all images. For example, in Word, you can add alternate 
text describing an image by using the Web tab of the illustrations Properties 
dialog box.

 

•

 

If you created an illustration out of several smaller illustrations, use the Group 
command to group them into a single illustration.
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Creating an accessible Adobe PDF file with a Microsoft Office 2000 
application

 

This section describes how to use Word 2000, Excel 2000, or PowerPoint 2000 to 
create an accessible Adobe PDF file. The instructions use a Word 2000 document 
as an example.

 

To create an accessible Adobe PDF file in a Microsoft Office Application:

 

1

 

Open the document in the Microsoft Office application.

 

2

 

Choose Acrobat > Change Conversion Settings.

 

3

 

Click the Office tab.

 

4

 

Select the options shown below. In particular, make sure Embed Tags in PDF 
is turned on and Page Labels is turned off. 

 

5

 

Click the Bookmarks tab in the dialog box. 
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6

 

From the list, select the styles for which you want to create Adobe PDF 
bookmarks. Then click OK.

 

7

 

Choose Acrobat > Convert to Adobe PDF on the Microsoft Office application 
menu bar, or click the Convert to Adobe PDF button on the application 
toolbar.

 

8

 

Name and save the file.

Congratulations, you've created an Adobe PDF file that retains both document 
content and structure. 

Before you publish the file, be sure to take advantage of the accessibility tools 
available in Acrobat 5.0. To do so, follow the instructions provided in “Using the 
Accessibility Checker” on page 21. If needed, use the Tags palette as described in 
“Using the Tags Palette” on page 23. When you’re done, test the file with a screen 
reader as described in “Testing Your Adobe PDF Files for Accessibility” on 
page 24.
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Working with Existing PDF Files

 

The great majority of existing PDF files have not been created with Microsoft 
Office 2000 applications. This section describes the basic steps for making these 
existing PDF files accessible.

 

To make existing PDF documents accessible:

 

Do one of the following, in order of preference:

 

•

 

If you have the original file on which the PDF was based, convert it to a new 
Adobe PDF file using the latest version of the originating application and 
Acrobat 5.0. Then follow the instructions in “Using the Make Accessible Plug-
in” on page 20.

 

•

 

If you don’t have the original file and authoring application, open the PDF file 
in Acrobat 5.0. Then follow the instructions in “Using the Make Accessible 
Plug-in” on page 20.

 

•

 

If the PDF file was created by scanning a paper document and then using 
Acrobat to save the bitmap image as an Adobe PDF file (also known as a PDF 
Image Only file), see “Working with Scanned and Paper Documents” on 
page 13.

Before you publish the file, be sure to take advantage of the accessibility tools 
available in Acrobat 5.0. To do so, follow the instructions provided in “Using the 
Accessibility Checker” on page 21. If needed, use the Tags palette as described in 
“Using the Tags Palette” on page 23. When you’re done, test the file with a screen 
reader as described in “Testing Your Adobe PDF Files for Accessibility” on 
page 24.
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Working with Scanned and Paper Documents

 

This section describes how to make tagged Adobe PDF files if your source 
document is a paper document, a scanned image of a paper document, or a PDF 
Image Only file.

You can use Acrobat 5.0 with a scanner to create a an Adobe PDF file from a paper 
document. However, the resulting file is a PDF Image Only file—that is, bitmap 
pictures of the pages. Although the file can be viewed in Acrobat, the text is not 
recognizable by the application as characters and words. Among other things, this 
means that the text displayed on those pages can’t be recognized as such by 
Acrobat or screen readers, and is therefore not accessible. 

If you want to be able to search, correct, and copy the text in a PDF Image Only 
file and make it accessible as tagged Adobe PDF, you need to “capture” the pages 
in the file with Adobe Acrobat Capture 3.0 software. Similarly, if you have 
scanned paper documents and have not saved the scanned images as Adobe PDF 
files yet, you can use Acrobat Capture to create tagged Adobe PDF files.

Adobe Acrobat Capture 3.0 enables you to set up customized workflows for your 
unique document-processing requirements. Here you’ll learn the basic steps 
needed to create a custom workflow that automates the steps for bringing in PDF 
Image Only files and scanned images, and making them accessible.

 

Important: 

 

You need the Tag Adobe PDF agent in order to create a tagged PDF file. 
This is a separate agent that will be available for purchase from Adobe in the second 
quarter of 2001. For more information, see the Acrobat Capture product page at 
www.adobe.com.

 

PDF Image Only workflow and image file workflow
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To set up a workflow for converting paper documents or PDF Image Only files to 

searchable, tagged Adobe PDF:

 

1

 

Set up a workflow in Acrobat Capture 3.0 that consists of these agents in 
this order:

 

•

 

(For PDF Image Only files) Split multipage PDF Image file to process each 
page of the PDF Image Only file.

 

•

 

(For PDF Image Only files) Convert Image to TIFF to make the image on each 
page usable for the optical character recognition (OCR) software that will be 
applied by the Capture Image agent.

 

•

 

Capture Image to apply OCR to each page as marked with the zone template. 
(The zone template lets specify areas on pages to treat as containing text 
or images.)

 

•

 

QuickFix Page to let you review and correct suspect text on each page.

 

•

 

Bind Pages to assemble the individual pages into a single document.

 

•

 

Export to PDF agent to save the file as an Adobe PDF file. 

 

•

 

Tag PDF to create a tagged Adobe PDF file. (This is a separately purchased 
plug-in available from Adobe.)

 

•

 

Store File (PDF) to store the file in Adobe PDF in the location you specify.

 

2

 

Click Done.

 

3

 

In the Configure palette, select the Export to PDF agent. Then right-click and 
choose Properties.

 

4

 

Click the General tab. For Page Content, choose Formatted Text and Graphics 
or Searchable Image Exact. (These are the only two flavors of Adobe PDF files 
that can be made accessible.) Then click OK. 
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5

 

In the Configure palette, select the Tag Adobe PDF agent. Then right-click and 
choose Properties.

 

6

 

Choose which language to use in discerning word breaks, select the options 
shown, and click OK.

 

7

 

In the Configure palette, select the Store File agent. Then right-click and 
choose Properties.

 

8

 

Enter a location in which to store the resulting tagged Adobe PDF files and 
click OK.
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To run the Acrobat Capture workflow you created:

 

1

 

Open Acrobat Capture.

 

2

 

Click the Configure palette tab.

 

3

 

Click the Run button ( ) for your Tag Adobe PDF agent in the Configure 
palette.

 

4

 

Click the Submit palette tab.

 

5

 

In that palette, select the folder or files you want to capture.

 

6

 

At the bottom of the Submit palette, choose how you want to treat files, and 
how you want to combine the images.

 

7

 

From the Target Workflow menu at the bottom of the Submit palette, choose 
the workflow you created.

 

8

 

Click the Submit to Workflow button at the bottom of the palette.

 

9

 

Use the QuickFix tool to review and correct suspect text on each page.

The image files are automatically assembled into a single file, exported to Adobe 
PDF with tagged Adobe PDF, and stored.

Before you publish the file, be sure to take advantage of the accessibility tools 
available in Acrobat 5.0. To do so, follow the instructions provided in “Using the 
Accessibility Checker” on page 21. If needed, use the Tags palette as described in 
“Using the Tags Palette” on page 23. When you’re done, test the file with a screen 
reader as described in “Testing Your Adobe PDF Files for Accessibility” on 
page 24.
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Working with Adobe PDF Forms

 

This section describes how to create form fields in the Adobe PDF file. Each field 
will be readable in the correct order and will include meaningful information 
about the field that can be presented to users by screen readers.

Generally, the first step in creating an accessible Adobe PDF form is to create a 
tagged Adobe PDF file from the original application file, or to convert a pre-
existing PDF file using the Make Accessible plug-in in Acrobat 5.0, as described 
earlier in this guide. However, many forms have graphically complex layouts that 
include small sections of text inside groups of tables, nested lists of instructions, 
and other arbitrarily formatted text and figures. Using the Make Accessible plug-
in on these kinds of documents may not always provide optimum results. 

Following are guidelines that will enable you to create tagged Adobe PDF forms 
using the Tags palette and the forms tool in Acrobat 5.0. This will enable you to 
create electronic Adobe PDF forms that include live, more accessible form fields 
that can be filled in using a computer keyboard.

 

To create tagged Adobe PDF forms:

 

1

 

Open the Adobe PDF form in Acrobat 5.0.

 

2

 

Choose Window > Tags to display the Tags palette. (For more information on 
the Tags palette, see “Using the Tags Palette” on page 23.)

 

3

 

Drag the Tags palette into the navigation pane where the other palettes are 
located and select it.

 

4

 

Right-click on No Tags Available in the Tags palette and choose 
Create Tags Root.

 

5

 

Select the column select tool ( ) from the toolbar.

 

6

 

Drag the pointer over the text you want to add to the structure tree 
in the Tags palette.

 

7

 

Once the text is selected, make sure the Tags Root is selected in the Tags 
palette. Right-click on the Tags Root and select Create Child Element from 
Selection. 

 

8

 

Repeat steps 6 and 7 until you’ve added all of the required text to the structure 
tree in the Tags Palette. Note that you can drag to rearrange elements in the 
structure tree if needed. 

You can now use the instructions below to add electronic form fields. 
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To add electronic form fields:

 

1

 

If you haven’t done so already, make the document into a tagged Adobe PDF 
file as described above.

 

2

 

Open the tagged Adobe PDF file in Acrobat 5.0.

 

3

 

Choose Window > Tags to display the Tags palette. (For more information on 
the Tags palette, see “Using the Tags Palette” on page 23.)

 

4

 

Drag the Tags palette into the navigation pane where the other palettes are 
located and select it.

 

5

 

Select the form tool ( ) from the toolbar.

 

6

 

Drag the cross-hair pointer to create a field of the required size where you 
want it on the form.

 

7

 

In the Field Properties dialog box, enter a name in the Name text box.

 

8

 

Enter a description of the field in the Short Description text box. The screen 
reader uses this information to describe the field to vision-impaired users.

 

9

 

Fill in any other options you want and click OK.

 

10

 

Choose Find Unmarked Comments from the palette menu in the Tags palette.

 

11

 

Select Search Current Page for Unmarked Content and click Find Next.

Acrobat highlights the field you just created with the form tool and describes 
the type.
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12

 

For Tag Title, enter a title. This information will not be read by the screen 
reader, but helps document authors identify fields within the structure.

 

13

 

For Tag Type, type 

 

Form

 

.

 

14

 

In the Tags palette, select the element under which you want to place the field.

 

15

 

Click Create Tag.

 

16

 

Repeat steps 6 through 15 for as many fields as you need, then close the dialog 
box when you’re done.

 

17

 

Save and close the file.

Congratulations, you've created a tagged Adobe PDF form that retains both 
document content and structure. 

Before you publish the file, be sure to take advantage of the accessibility tools 
available in Acrobat 5.0. To do so, follow the instructions provided in “Using the 
Accessibility Checker” on page 21. If needed, use the Tags palette as described in 
“Using the Tags Palette” on page 23. When you’re done, test the file with a screen 
reader as described in “Testing Your Adobe PDF Files for Accessibility” on 
page 24.
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Using the Make Accessible Plug-in

 

The Make Accessible plug-in enables Acrobat 5.0 to convert untagged PDF files, 
such as those created with Acrobat 4.0, to accessible (tagged) Adobe PDF. This is 
useful if you are working with older PDF files for instance, or files that were not 
made in Microsoft Office 2000 applications. The Make Accessible plug-in will be 
available as a free download at the Adobe Web site at www.adobe.com, and at 
access.adobe.com in the second quarter of 2001.

This section describes how to process a single document. However, the Make 
Accessible command can also be used with the batch-processing feature in 
Acrobat 5.0 to process multiple documents.

You do not need to run the Make Accessible command if you did either of the 
following:

 

•

 

Created a tagged Adobe PDF file using Microsoft Office 2000 as described in 
“Working with Microsoft Office 2000 Application Files” on page 9.

 

•

 

Created a tagged Adobe PDF file from scanned images using Adobe Acrobat 
Capture 3.0 as described in “Working with Scanned and Paper Documents” 
on page 13.

 

Important: 

 

You should always check the resulting tagged Adobe PDF file with a 
screen reader to make sure everything is correct. For example, in a page with a very 
complex layout, the Make Accessible plug-in may have difficulty determining the 
logical reading order, so it may put paragraphs in the wrong order. This problem 
won't be noticed by the Accessibility Checker because it can't read through the 
document to see if it makes sense; it can only check to see if all of the text has been 
tagged and put in the structure tree. 

 

To use the Make Accessible command:

 

1

 

Open the PDF file in Acrobat. 

 

2

 

Choose Document > Make Accessible.

 

3

 

Use the Accessibility Checker as described in “Using the Accessibility 
Checker” on page 21.

 

4

 

Use the Tags palette as described in “Using the Tags Palette” on page 23 to 
check the structure of the document.

 

5

 

Choose File > Save As.
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6 Name and save the file.

Note: Using Save As, rather than Save is highly recommended because the Make 
Accessible plug-in makes changes to the internal structure of the document which 
cannot be reversed.

7 Test the file with a screen reader when you are done, as described in “Testing 
Your Adobe PDF Files for Accessibility” on page 24.

Using the Accessibility Checker
Once you have created a tagged Adobe PDF, you are ready to verify the files and 
optimize them using the Accessibility Checker and the Tags palette in Acrobat 5.

To verify the files and fix them if necessary:

1 Open the tagged Adobe PDF file in Acrobat.

2 Choose Tools > Accessibility Checker.

3 Select the options as shown in the dialog box below and click OK.
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If the Accessibility Checker finds any potential problems, it will display a dialog 
box explaining what they are and will put comments into the Tags palette to 
indicate what parts of the document may have problems. This will make it easier 
to find and fix the problems. Most potential problems can by fixed by using the 
Tags palette in Acrobat to add or modify the structure of the tagged Adobe PDF 
file, as described in “Using the Tags Palette” on page 23. 

Note that the Accessibility Checker might report problems with elements in a 
tagged Adobe PDF file that are things you can safely ignore. For example, it might 
report that there are images in the file that do not have alternate text. However, if 
these images are just the decorative borders on the page, they would be unnec-
essary for someone with a vision impairment, and would not require alternate 
text. Similarly, the Accessibility Checker might report that a running header is not 
part of the structure tree. Again, you could leave this as is, since you don't need 
this information to be vocalized by a screen reader.

If a form field is missing descriptive text, you can fix it with the form tool as 
described in “Working with Adobe PDF Forms” on page 17.

When you’re done, test the file with a screen reader as described in “Testing Your 
Adobe PDF Files for Accessibility” on page 24.
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Using the Tags Palette
Tags define the structure and reading order of a tagged Adobe PDF file. The Tags 
palette lets you look at these tags—in other words, the underlying structure of the 
document—and modify them.The following instructions describe how to display 
the Tags palette in Acrobat and typical items you might want to fix in the 
structure of a tagged Adobe PDF file using the palette. 

Note: This section assumes you are opening a tagged Adobe PDF file. If you open a 
standard PDF file, the Tags palette will indicate the file has no tags.

To access the Tags palette:

1 Choose Window > Tags to display the Tags palette. 

2 Drag the Tags palette into the navigation pane where the other palettes are 
located and select it.

 

To add missing alternate text:

1 Find and select the element that is missing the alternate text, such as an image, 
in the Tags palette.

Note: Selecting Turn On Associated Content Highlighting from the Tags palette 
menu can help you find elements. With this option selected, any item you select in the 
Tags palette is highlighted in the body of the document.

2 Right-click the mouse and choose Element Properties.

3 Enter the alternate text in the Alternate Text field, and click OK.
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To specify the text language of the document:

1 In the Tags palette, find and select the element or subtree that does not have a 
text language defined for it. It is best to tag this as high in the document 
structure tree as possible, to specify the text language for all the elements 
contained within the element or subtree.

2 Right-click the mouse and choose Element Properties.

3 Choose a language from the Language menu in the dialog box. The language 
encodings are based on ISO standards. The languages and their respective 
codes are as follows:

4 Click OK.

When you’re done, test the file with a screen reader as described in “Testing Your 
Adobe PDF Files for Accessibility” on page 24.

Testing Your Adobe PDF Files for Accessibility
Once you have a tagged Adobe PDF file, it’s strongly recommended to test the file 
using a screen reader. This will show you how the information in the document 
will actually be presented to users, and how well such things as the reading order 
and navigational links will work.

To test Adobe PDF files for their accessibility with screen readers:

1 Start a screen reader, such as GW Micro’s Window-Eyes or Freedom Scien-
tific’s JAWS for Windows. 

2 Start Acrobat and open the Adobe PDF file in it.

3 Use the screen reader to read the document. For more information on either 
screen reader, see the documentation that came with it.

• Brazilian Portuguese: PT-BR • French: FR
• Chinese: ZH • German: DE
• Danish: DA • Italian: IT
• Dutch: NL • Japanese: JA
• English: EN • Korean: KO
• US English: EN-US • Norwegian: NO
• UK English: EN-GB • Spanish: ES
• Finnish: FI • Swedish: SV
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Appendix A: Troubleshooting
This appendix provides common solutions to problems that you may encounter 
when creating and optimizing Adobe PDF files, so that they can be made acces-
sible to users with vision or motion impairment.

Text is unreadable because the Adobe PDF document has been password 
protected, and content copying and extraction are not allowed. In Acrobat 4.0, 
assigning password security that disallowed copying and pasting made the page 
content inaccessible. However, in Acrobat 5.0, a new security setting has been 
added that lets you disallow copying and pasting, but still enables Content Acces-
sibility. 

To use this setting, choose File > Document Security. Then choose Change 
Settings. Choose 128-Bit RC4 (Acrobat 5.0) from the Encryption Level menu and 
select Enable Content Access for the Visually Impaired. Select any other security 
options you want and click OK. 

Text in an Adobe PDF document—such as columns, headers, and footers—isn’t 
read in the correct order by a screen reader. To solve this problem, do one or 
more of the following when creating a tagged Adobe PDF file according to the 
instructions in this guide:

• Create your original document using a Microsoft Office 2000 application 
or another application that helps indicate the logical reading order when 
converted to Adobe PDF.

• When creating your original document in Microsoft Word 2000, use styles to 
format text such as titles, headings, and paragraphs. The styles provide 
structure information when you create a tagged Adobe PDF file.

• If your original document is created with a Microsoft Office 2000 application, 
create a tagged Adobe PDF file in the Microsoft Office 2000 application. For 
instructions, see “Working with Microsoft Office 2000 Application Files” on 
page 9.

• If you are working with an unstructured Adobe PDF file, convert it to a tagged 
Adobe PDF file using the Make Accessible plug-in with Acrobat 5.0. For 
instructions, see “Using the Make Accessible Plug-in” on page 20.

• Touch up the reading order of elements in the logical structure tree of your 
structured or tagged Adobe PDF file using the Tags palette in Acrobat 5.0.
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Adobe PDF document doesn’t provide an overview of its content. To solve this 
problem, add bookmarks to your Adobe PDF document by doing one or more of 
the following when creating a tagged Adobe PDF file according to the instruc-
tions in this guide:

• When creating your original document in Microsoft Word, use styles to 
format text such as titles, headings, and paragraphs. Then convert selected 
styles to bookmarks by creating a tagged Adobe PDF file according to instruc-
tions in “Working with Microsoft Office 2000 Application Files” on page 9.

• If you are working with an unstructured Adobe PDF file, convert it to a tagged 
Adobe PDF file using the Make Accessible plug-in with Acrobat 5.0. For 
instructions, see “Using the Make Accessible Plug-in” on page 20. 

• Add bookmarks manually to your Adobe PDF document using Acrobat 5.0.

Adobe PDF document contains bitmapped images, but there are no text 
descriptions for those images. To solve this problem, add alternate text descrip-
tions for the images by doing one of the following:

• When you create your original document, add alternate text descriptions for 
the images. For example, in Microsoft Word, you can use the WordArt object, 
add text to a shape, or specify alternate text for images on a Web page. Then 
create a tagged Adobe PDF file according to instructions in this guide. (In 
Word 2000, you can double-click an image to display the Format Picture 
dialog box, which includes the Web tab. The Web tab allows you to add 
alternate text to an image.)

• Add alternate text descriptions for images to a tagged Adobe PDF document 
using the Tags palette in Acrobat 5.0. For instructions, see “Using the Tags 
Palette” on page 23.

Text is unreadable or garbled in an Adobe PDF document that has a complex 
layout. To solve this problem, do all of the following when creating a tagged 
Adobe PDF file according to the instructions in this guide:

• When you create your original document, don’t overlap elements. Make sure 
that text and images are visually separate on each page.

• If you created an illustration out of several smaller illustrations in your 
original document, use the Group command if available to group them into a 
single illustration.
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Table data in an Adobe PDF document isn’t read in the correct order by a screen 
reader. To solve this problem, create your original document using a Microsoft 
Office 2000 application. If you are using Microsoft Word, use the Insert Table 
command or Draw Table tool to create tables (don’t use tabs to simulate a table). 
Then create a tagged Adobe PDF file in the Microsoft Office 2000 application. For 
instructions, see “Working with Microsoft Office 2000 Application Files” on 
page 9. Alternatively, you can use the Make Accessible command, as described in 
“Using the Make Accessible Plug-in” on page 20 with simple tables.

Web pages converted to Adobe PDF using Web Capture with Acrobat 5.0 is not 
accessible. A Web page is only as accessible as the HTML source code it is based 
on. For example, if tables were used to design the layout of the Web page (as is 
typical of most Web pages) the source HTML text may not flow in a logical order. 
To get the most accessible Web pages, the pages should be created to read in a 
logical order. Additionally, to ensure the document is converted to tagged Adobe 
PDF, choose Tools > Web Capture > Open Web Page. Then click Conversion 
Settings, select Add PDF Tags, and click OK.

Text is unreadable or garbled in an existing Adobe PDF document that contains 
TrueType fonts, text on a path, or other anomalies. To create a tagged Adobe 
PDF file from an existing Adobe PDF file that contains these types of anomalies, 
re-create the Adobe PDF file from its original using the latest version of the origi-
nating application and Acrobat Distiller with Acrobat 5.0. Then follow the 
instructions in “Using the Make Accessible Plug-in” on page 20.

Text is unreadable in an Adobe PDF file that contains only a scanned image of a 
document. To solve this problem, make the text in the Adobe PDF document 
searchable and accessible by using Adobe Acrobat Capture 3.0. For instructions, 
see “Working with Scanned and Paper Documents” on page 13.

Forms in an Adobe PDF document are unreadable or garbled. To solve this 
problem, use Acrobat 5.0 to create form fields in your Adobe PDF document that 
include meaningful information and can be read in the correct order by a screen 
reader. For instructions, see “Working with Adobe PDF Forms” on page 17.
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Appendix B: Setting Acrobat 5.0 for High-Contrast 
Viewing
Adobe Acrobat 5.0’s Accessibility preferences can make the information in Adobe 
PDF files easier to view for people who have trouble discerning variations in 
contrast, different colors, or who have low visual acuity. These people can set the 
accessibility preferences as their application default. In addition, you might want 
to consider testing your tagged Adobe PDF documents with high-contrast 
viewing to check for any accessibility problems in that regard.

To change Acrobat 5.0 accessibility settings for high-contrast viewing:

1 Open the tagged Adobe PDF file in Acrobat 5.0.

2 Choose Edit > Preferences > General.

3 Select Accessibility from the list of preferences.

4 From the Color Scheme menu, choose Use Custom Scheme.

Note: Windows also supports a high-contrast viewing mode. If you’ve already set up 
your Windows system for this mode, you can choose Use Windows Colors instead.

5 In the Custom Scheme area, set the Text Color to your preferred colors, such 
as bright green.

6 From the Adjust Display of Colors menu, choose Always Overriding 
Document Colors.

7 Set the Page Background Color to a contrasting color, such as black.

8 Click OK.

Note: If the file is a tagged Adobe PDF, you can also zoom in on the text to magnify 
it and click the reflow button in the toolbar. This can make the document easier to 
read for people with low-vision problems.
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